Ubiquiti and Networking Nirvana

For years, I’ve struggled with getting good networking at my house. We had our previous house custom built, and I had it wired thoroughly with CAT5 and RG-6. In my current house, there are coax drops in every room, but some are shorted, some I can’t trace, and some are shared among several outlets. It’s bizarre. There are a few RG11 ports and one RG45 — with a switch? — which I presume all go to the SBC box on the side of my house, to which I have no access.

When we first moved in, I upgraded to a monster Asus WiFi router in my office, which is in the basement. It was OK in the basement, and on the main floor, but spotty on the second floor, of course. Then it burned out. No problem, right? These days, there are lots of mesh WiFi systems on the market.

My next move was to get a Netgear Orbi. It worked, sort of. The problem was that it needed to be rebooted every few days. After months and months of this hassle, and one day where I had to reboot the stupid thing multiple times in a single day, I finally — literally — unplugged the unit in my office, and smashed it on the floor, to force myself to do something else.

I drove straight over to Best Buy, and bought a Linksys Velop, and… immediately regretted my life choices. Linksys’ setup application is even worse than Netgear’s. It’s a clown show of an IoT piece of junk. I fought through it, and finally got the system setup, and the speeds were decent. However, I found that every time I looked at the status on the app, the “middle” floor unit was offline, and needed to be rebooted. Then, one day, the whole system lost its mind, and needed to be re-setup from scratch. I continued to put up with these hassles, rebooting the one unit, and occasionally needing to reset a node.

This is where this story, and its followup, fits into this timeline.

Lest you think my experience with the Velop is an aberration, a good friend of mine has worked for many, many hours with Linksys tech support on his system, and after getting sent several particular firmware versions to try, was recently sent an entirely new set of units.

I had an Aha! moment, and bought 2 pairs of TP Link Powerline adapters to run a “backhaul” line for each of the 2 remote WiFi access points. This seemed to work better. The main floor unit stopped going offline. I thought I was finally on easy street.

Then one day, the entire system lost its mind again. The Comcast service had “locked up” on my modem — again — but this seemed to cause the Velop to not only stop working, but lose its configuration. Given how the setup app basically doesn’t work unless it can “phone home,” I guess it scrammed itself because of this. Whatever the reason, I found this completely unacceptable. I had to get WiFi working again, but I could only pair one of the secondary units. The other just completely refused to work again.

So I ordered a Ubiquiti Dream Machine, and 2 of their NanoHD access points. I use a lot of their gear for networking and security cameras at our church, and it’s not without a learning curve specific to their way of working, but since I knew what I was getting into, and I could afford it, I figured this was my only option left. At this point, I am convinced that all consumer-grade mesh systems on the market are just rubbish. I wasn’t willing to try Amazon’s or Google’s, or whatever. I thought that my existing Powerline adapters would provide the wired connection for the wired-only AP’s to get to the router.

I got the thing all setup, but my speeds were lacking. I pay for gigabit, but I don’t worry much about getting the whole thing. I know that’s not realistic. However, I tried to play Battlefield again, after a long hiatus, and I kept lagging out. Like, every minute. I realized that my Comcast setup was just not working right. Turns out that I was only getting 200 Mbps, and even that was spotty. I spent several hours trying different things and talking to their tech support — twice — and finally got them to straighten it out.

Then I tried to get my son to play Battlefield with me, and he kept lagging out. So I started working on the inside part of the network. I saw that TP Link offers an application to look at their Powerline adapters, and it will report the bandwidth you’re actually getting. I saw that my “backhaul” connections were only getting 100-200 Mbps. In effect, these adaptors were doing exactly what I needed them to do with the Velop: they kept the systems talking just enough to keep them from dropping offline, but continued to use the “mesh” for the actual WiFi traffic. Anyway, I reconfigured the 2 pairs into a single, 4-node network, hoping that this would improve the situation, but it made no difference. In the same room, power line adapters will get near their advertised 2 Gbps, but once you put them across circuits in your house’s electrical panel, the bandwidth is cut by a factor of 10.

In the beginning, I had used a pair of ActionTec coax adaptors to extend my network over to my boys’ PC’s, when they were in the basement. However, the unit I had was capped at 100 Mbps. I wanted to try the new ones rated for gigabit, but was nervous that they would work only as well as the Powerline adaptors. But the Amazon reviews — which, I know, goes against everything I believe about Amazon and ratings systems in general — kept saying that power line adaptors weren’t all they were cracked up to be, and that these were the real deal, and I believed them. So I bit the bullet, fully prepared to send them back. After a lot of tracing and fiddling, I got them setup where they could reach my access points, and they worked… great! This was the final straw to making everything work. They don’t have an app to look at effective bandwidth, but testing from my son’s Playstation shows that he can get 800+ Mbps all the way out the door.

And I haven’t lagged since.

I find myself looking at my Ubiquiti dashboard, and reveling in WiFi nirvana. I can’t believe how much money I’ve spent getting to this point, but now that it’s working like I expect, and it hasn’t missed a beat for many days now, so it feels like it’s been worth it.

To their credit, another friend has Ubiquiti’s Amplifi mesh product, and he says it’s been flawless for him. I was tempted to try their “Alien” version, with multiple units in a mesh configuration, but that would have been even more expensive than what I’ve got now.

Leave a Reply

Your email address will not be published.